ロード日記~3つの趣味を持ちましょう~

釣り、自転車、カメラなど趣味の日記です。 最近は自転車にはまってますのでこれがメインです。 その他、思いのままにあったことを書いてくブログです。

| PAGE-SELECT |

≫ EDIT

【コーディング】トラブル解決と再設定

先日エラーメッセージが出た320dですが、一応解決しました。
ENETケーブルで接続できず、どうにもならないのでディーラーで見てもらったところ、プログラムのアップデートではなくいくつかの設定を元に戻したようです。

かえってきた車を見ると、ナビロックやリーガルディスクレーマはそのままになっていましたが、デイライトと複数の設定がリセットされています。全リセットではないので、I-stepもバージョンアップされていないのである意味親切だったのかな?
いずれにしても、ディーラーのお世話にになるのはよくないので今後は慎重に作業しよう。

○ENETケーブル
 通信エラーが発生した原因が車両だと思っていたが、なんとケーブル自体であることが判明しました。
 510Ω抵抗がODB2コネクタケース内でネジ穴と干渉しており、ケーブル抜き差しの圧力でハンダつけ部分が折れてしまっていた。
 なんということだ。慣れていないのもあるが、懸念していた点なのに。
 ケーブルを疑って分解はしたのだが、ハンダの断線は目視ではわからなかった。テスターを使えればよかったのだが・・
 結局、すべての配線を外して再度ハンダ付けを実施。抵抗は接触しないような角度で付け直した。

○バックアップ
 車両接続後、問題なくコネクトできたら「FA」「SVT」をそれぞれセーブする。
 また、コーディング対象となる
 FEM_BODY / HU_NBT / KOMBI を読み込んだら
 c:\Data\CAF\の下にできた*.ncdをバックアップしておいた。

 このとき気づいたのが、最後に修正していたFEM_BODYを示すファイル名が
 以下のように変わっていた。

 旧:CAFD_00000794_015_041_202.ncd
 新:CAFD_00000794_015_041_203.ncd

 上記2ファイルを「NcdCafdTool_V0.3.6」を使ってDiffをとると一発でコンフィグ差異が出るので非常に便利
 結局想定していた場所以外の違いは見当たらなかった。

○再コーディング
設定はFEM_BODYに集中していたので、一度にすべて変更して1回で書き込みを行い、無事成功した。
成功後、センサーエラーのメッセージが出たがいつもの通り。その後、ケーブルは認識するものの、接続しようとするとECUからのレスポンスがないメッセージが出て焦った。
しばらくするとconnection establishedが出て一安心だが、その間にiDriveが勝手にリセットされるなどちょっと不穏な動きが見られたのが心配ではある。
コーディング後、すべての機能が正常に動作し、エラーメッセージも出ず問題なく過ごせている。

実行したコーディングは以下の通り
No 設定内容 Unit param 標準値 設定値
1 リーガルディスクレーマ HU_NBT LEGAL_DISCLAIMER_TIME ld_mit_timeout klein_ld
2 ナビロック解除(MIN) HU_NBT SPEEDLOCK_X_KMH_MIN 08 FF
3 ナビロック解除(MAX) HU_NBT SPEEDLOCK_X_KMH_MAX 0A FF
4 デイライトメニュー表示 HU_NBT Daydriving_light Perm_off standard
5 デイライト機能有効化 FEM_BODY TFL_MODUS Off tfl_s
6 デイライト時リング照度 左 FEM_BODY MAPPING_TAGFAHRL_V_L_PWM_LEVEL_1 64 32
7 デイライト時リング照度 右 FEM_BODY MAPPING_TAGFAHRL_V_R_PWM_LEVEL_1 64 32
10 ドアロック時即時ドアミラー閉 FEM_BODY KOMFORT_SCHLIESSEN 0F 00
11 ターンシグナル回数変更 FEM_BODY BLINKZYKLEN_ANZAHL_TIPP 02 04
15 GPS連動時刻補正 KOMBI GPS_UHR night_aktiv aktiv
16 アンビエントとインパネライトの分離 FEM_BODY Ambiente_Nachfuehrung aktiv nicht_aktiv
17 ドアオープンでiDrive電源OFF FEM_BODY TCM_LOGIC_R_OFF_DOOR nicht_aktiv aktiv
18 トランクリッド開閉開始時間 FEM_BODY CLM_TIMEOUT_HK_SMO wert_04 wert_01
スポンサーサイト

| 車 パーツ | 22:39 | comments:0 | trackbacks:0 | TOP↑

≫ EDIT

【コーディング】やってもうたか!E-sysが繋がらなくなった

年始以来、しばらくやっていなかったコーディング項目を調査したのでやってみました。
ところが、コーディング後、再接続できず設定をいじれなくなってしまいました。

設定した項目

今回複数の設定を行い、結果としてはすべてうまくいった。
○トランクリッドオープン時間変更
まず、コンフォートアクセスのトランクオープンにかかる時間に関して以前の設定は誤っていたのでこれを修正する。
誤: FEM_BODY→RC_TIME_DELAY_BOOTLID を00から05に戻す
正: FEM_BODY→CLM_TIMEOUT_HK_SMO
    werte_04 -> werte_01

最初はwerte_00にして更新しようとしたのですが、最後にwerte_01にしました。

○アンビエントライトとインパネライトの分離
 FEM_BODY->Ambiente_Nachfuehrung
  aktiv->nicht_aktiv

○ドアオープンでiDrive電源をOFFにする
 FEM_BODY->TCM_LOGIC_R_OFF_DOOR
  nicht_aktiv->aktiv

No ZGW available

まず、全項目を一度に設定して書き込み(code FDL)をしようとしたら、エラーが発生してしまった。
いったん、エンジン再始動しE-sysを再接続するとコネクト成功したため、改めて設定を見ると書き込みは行われていないように見え、設定は元に戻っていた。気を取り直して一項目設定し、正常に反映されるのを確認してから3項目を一気に設定し反映した。
その後、挙動を確認しすべてうまくいっていたことを確認したのち、エンジン停止した。

問題はここから。洗車のためにエンジンを始動し停止したときに、「カメラによるドライバアシスタントシステムに異常が発生しました」のエラーが発生。iDriveから詳細を読むと、自動ハイビームができないので手動でとあり、どうやらアダプティブLEDヘッドライトに関するエラーコードのよう。アダプティブLEDは搭載していないので、カメラアシストが関係するのはレーンディパーチャウォーニングくらいだが正常に機能しているので、やはり故障ではないだろう。

いったん設定を元に戻すため、ケーブルをつないでE-sysをconnectしようとすると「connection via VIN」がNo ZGW availableになっていてコネクトできない。それ以来、エンジン再起動もPC再起動も何をしてもつなげないようになってしまった。

インターネットで調べてみると以下のような記事がbimmerpostにあった。
http://f30.bimmerpost.com/forums/showthread.php?t=1023053&highlight=No+ZGW+available
車をロックして、2-3時間放置すると再接続できるようになるというもの。1時間程度でよいとの書き込みもあったがそれではダメだったので、後程確認してみることにしようと思う。

それにしても、なぜ最初に更新エラーが出たのだろう。ログを見ているのだが何が原因がわからない。トランクリッドの設定値をwerte_00にして一度に更新しようとしたのが原因か、ノートPCのバッテリーが20%くらいだったからなのか・・・
次回はちゃんとバックアップを取ることにしよう。さあ、ちゃんと治るのだろうか。ドキドキ

| 車 パーツ | 22:37 | comments:0 | trackbacks:0 | TOP↑

| PAGE-SELECT |